Back to overview
Resolved

Examining Delayed Deliveries

Jul 2, 2026 at 8:37pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Jul 2, 2026 at 8:53pm UTC

Delivery speeds were elevated up to ~5 minutes. They have returned to normal.

We will implement mitigation strategies over the next 24 hours to prevent this from recurring.

Created
Jul 2, 2026 at 8:37pm UTC

Email delivery is delayed, we're investigating.