Back to overview
Degraded
Examining Delayed Deliveries
Jul 1, 2026 at 1:09am UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Jul 1, 2026 at 1:19am UTC
There was a brief delay in mail deliveries due to a large spike in traffic. Things have returned to normal, and we are continuing to monitor things.
We have identified a performance issue, and will rectify it so such a spike does not cause delay in the future.
Affected services
Created
Jul 1, 2026 at 1:09am UTC
Our alerting says deliveries are delayed. We're taking a look.
Affected services