Back to overview
Degraded
Investigating Delayed Deliveries
Jun 24, 2026 at 11:29pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Jun 25, 2026 at 12:34am UTC
Mail delivery speed has returned to normal.
We experienced a spike in traffic, and our autoscaling wasn't configured aggressively enough to keep up. We've tuned the autoscaling so this will not happen again in the future.
Affected services
Created
Jun 24, 2026 at 11:29pm UTC
Were investigatingreports of delayed mail deliveries.
Affected services