Get in touch
Back
Downtime

Dashboard is unavailable

Started 27 May at 11:51am CEST, resolved 27 May at 11:58am CEST.

app.improvmx.com api.improvmx.com
Resolved

We've identified the issue and it's been automatically resolved by our redundancy plan. There will be no further updates.

Posted 27 May at 11:58am CEST.
Created

The dashboard is currently unavailable for all users. Email forwarding isn't impacted. We will update in 15 minutes with more information.

Posted 27 May at 11:51am CEST.