Back to overview
Downtime
Examining expired SMTP certificate
May 15, 2026 at 4:42am UTC
Affected services
smtp.improvmx.com
Resolved
May 15, 2026 at 5:16am UTC
We have pushed a fresh certificate, and SMTP sending functionality has been restored.
We will investigate and post a full postmortem tomorrow.
Affected services
Created
May 15, 2026 at 4:42am UTC
Examining reports of expired SMTP certificate affecting ImprovMX SMTP sending.
Affected services