Back to overview
Degraded

Investigating deliverability issues across all providers.

Apr 10, 2026 at 12:10am UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Apr 10, 2026 at 2:09am UTC

Deliveries seem to be back to normal, we will root cause this and post a postmortem.

Created
Apr 10, 2026 at 12:10am UTC

We're seeing reports of deliverability issues for all email providers.