Back to overview
Downtime

Investigating downtime

Apr 8, 2026 at 5:02pm UTC
Affected services
app.improvmx.com
api.improvmx.com
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Apr 9, 2026 at 1:02pm UTC

Updated
Apr 8, 2026 at 9:58pm UTC

api and app have recovered, we will continue monitoring.

Apologies for the downtime, a full postmortem will be posted tomorrow.

Updated
Apr 8, 2026 at 9:55pm UTC

Mail delivery has recovered. API servers are still degrading and we're investigating

Updated
Apr 8, 2026 at 9:50pm UTC

We've killed a bad query on the primary database, and services have recovered. We will continue monitoring.

Updated
Apr 8, 2026 at 9:37pm UTC

recurrence of issue, we're investigating

Updated
Apr 8, 2026 at 5:32pm UTC

app.improvmx.com and api have returned to normal.

All services have recovered.

Postmortem will be posted tomorrow.

Updated
Apr 8, 2026 at 5:27pm UTC

Mail delivery has recovered. We are still investigating app/api.

Updated
Apr 8, 2026 at 5:18pm UTC

We've upgraded our primary database, and are seeing services recover.

Created
Apr 8, 2026 at 5:02pm UTC

We are having issues with our primary database, affecting all services.