Back to overview
Degraded

Delayed Mail Forwarding

Apr 1, 2026 at 8:41pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Apr 1, 2026 at 8:53pm UTC

We had a brief spike in emails forwarded through our system. Our system auto-scaled to handle the spike, and services are back to normal.

We will continue to monitor our systems, and implement better auto-scaling policies to prevent this in the future.

Created
Apr 1, 2026 at 8:41pm UTC

We're investigating delayed email forwardings.