Back to overview
Degraded
Delayed Mail Forwarding
Mar 30, 2026 at 05:46pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Mar 30, 2026 at 06:37pm UTC
This is a similar pattern to the incident a few days ago. We've applied the same mitigation methods (a lot faster this time), and services are returning to normal.
We will continue monitoring our systems, and implementing greater resilience to prevent these incidents in the future.
Affected services
Created
Mar 30, 2026 at 05:46pm UTC
We're investigating delayed email forwardings.
Affected services