Back to overview
Degraded
Delayed Mail Forwarding
Mar 27, 2026 at 03:42pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Mar 27, 2026 at 08:42pm UTC
We mitigated a prolonged DDOS attack with many spam senders overloading our mail servers.
All mail deliveries are back to normal now.
PostMortem with more detailed information will be posted tomorrow.
Affected services
Created
Mar 27, 2026 at 03:42pm UTC
We're investigating delayed email forwardings.
Affected services