Get in touch
Back
Resolved

Marketing site + App unavailable - Netlify outage

Started 2 May at 10:07am CEST.

www.improvmx.com app.improvmx.com
Created

Netlify, our hosting provider for the marketing site and app.improvmx.com is currently experiencing an outage.

https://www.netlifystatus.com/incidents/m1d4vwctxsrs?u=vy7qn93y8qbp

Posted 2 May at 10:07am CEST.