Back to overview
Degraded
Investigating Deliverability Issues to live.com and outlook.com email destinations
Feb 23 at 02:26pm EST
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Feb 23 at 03:30pm EST
Microsoft inbox delivery continues to recover, we will continue to monitor the situation.
Affected services
Updated
Feb 23 at 03:17pm EST
We have deployed a mitigation and are seeing recovery for microsoft inbox delivery (hotmail.com and live.com).
(outlook.com is unaffected)
Affected services
Created
Feb 23 at 02:26pm EST
We're seeing an uptick in email deliverability issues to live.com and outlook.com
Affected services