Back to overview
Degraded

Investigating delayed delivery times.

Oct 08 at 10:28am EDT
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Oct 08 at 01:10pm EDT

PostMortem posted to our blog: https://improvmx.com/blog/post-mortem-2025-10-08

Updated
Oct 08 at 11:23am EDT

Delivery times are back to normal.

PostMortem will be posted later today with our findings.

Updated
Oct 08 at 11:11am EDT

Mitigation seems successful, delivery times are returning to normal.

Updated
Oct 08 at 11:04am EDT

We've identified a SQL performance issue, and are attempting a mitigation.

Created
Oct 08 at 10:28am EDT

Currently investigating some reports of delayed delivery times.