Investigating increased error rates on deliveries and api.improvmx.com
Resolved
Oct 5, 2025 at 2:36pm UTC
Post Mortem has been posted to improvmx.com/blog/2025-10-05-post-mortem-sql-servers-overloaded
Affected services
Updated
Oct 5, 2025 at 1:14pm UTC
We upgraded our SQL servers to handle more capacity, and service has returned to normal.
Post Mortem to be posted later.
Affected services
Updated
Oct 5, 2025 at 12:22pm UTC
This is affecting forwarding as well.
Affected services
Created
Oct 5, 2025 at 12:18pm UTC
We're seeing increased error rates on api.improvmx.com
Affected services