Delayed Email Deliveries
Resolved
Oct 04 at 05:54pm EDT
Post Mortem has been posted to improvmx.com/blog/post-mortem-backed-up-delivery-queue
We sincerely apologize for the downtime here, this doesn't meet our reliability bar. We will diligently make improvements to prevent this kind of issue going forward.
Affected services
Updated
Oct 04 at 08:54am EDT
We've churned through our backlog of emails.
Email delivery is back to normal now.
Full PostMortem will be posted later today to this status page and to https://improvmx.com/blog
Affected services
Updated
Oct 04 at 08:09am EDT
NOTE: OpenSRS/hostedemail.com mail servers seem down, any customers with those inboxes will not be receiving emails until they recover.
Affected services
Updated
Oct 04 at 07:55am EDT
We have mitigated the issue, our mail servers are making their way through the backlog of queued emails.
We will post again when the queue is complete and email delivery is back to normal.
A full postmortem will be posted tomorrow.
Affected services
Updated
Oct 04 at 07:18am EDT
We have identified the root cause, and are mitigating the issue now. Emails queued for delivery are beginning to come through.
We will post another status update soon.
Affected services
Created
Oct 04 at 05:33am EDT
We are currently investigating increased error rates on email deliveries.
Affected services