Back to overview
Degraded
Degraded deliverability against Microsoft email servers.
Jul 24 at 02:00pm EDT
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
Jul 25 at 02:58am EDT
We have rotated in a new set of sending IPs, and we're seeing Microsoft deliverability rates return to normal. We will continue monitoring this over the coming days.
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Created
Jul 24 at 02:00pm EDT
We're currently experiencing degraded deliverability to Microsoft email servers (outlook, live, hotmail, etc.).
We're working on rotating in a new set of IPs to resolve the situation.
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com