Back to overview
Degraded
Impacted Delivery with Microsoft live.com and outlook.com mailboxes
Jun 10 at 01:42pm EDT
Affected services
mx1.improvmx.com
mx2.improvmx.com
Resolved
Jun 11 at 06:46am EDT
We have rotated out affected sending IPs, and microsoft deliverability is returning to normal.
Affected services
mx1.improvmx.com
mx2.improvmx.com
Created
Jun 10 at 01:42pm EDT
We're currently investigating impacted email forwarding to Microsoft mailboxes.
Affected services
mx1.improvmx.com
mx2.improvmx.com