Back to overview
Degraded
SPF Record Change Impacted Deliveries
May 02 at 01:00am EDT
Affected services
mx1.improvmx.com
mx2.improvmx.com
Resolved
May 02 at 11:26am EDT
The SPF record issue has been resolved.
Affected services
mx1.improvmx.com
mx2.improvmx.com
Created
May 02 at 01:00am EDT
We pushed out a bugged SPF record change last evening (05/02/2025) at 11:30PM Eastern US Time.
It was designed to improve email deliverability by reducing the number of SPF lookups, but had an issue that temporarily caused SPF lookup failures.
We have pushed corrected SPF records as of 05/02/2025 11AM Eastern US Time. This will require a few hours to fully propagate.
Affected services
mx1.improvmx.com
mx2.improvmx.com