Back to overview

Delayed Email Delivery

Feb 18 at 07:07am EST
Affected services
mx1.improvmx.com

Resolved
Feb 18 at 08:53am EST

PostMortem:

We have identified actors spamming our load balancers with traffic which affected a portion of users. We have banned the bad actors, added enhanced logging and alerts to the affected load balancers, and will act accordingly the next time this happens.

Created
Feb 18 at 07:07am EST

Email deliverability has returned to normal for most users. We are continuing to investigate.