Get in touch
Back
Maintenance

Notice of Upcoming Maintenance Impacting Alias Testing

Completed 6 Sep at 01:00am CEST.

app.improvmx.com
Completed

Maintenance completed

Posted 6 Sep at 01:00am CEST.
Started

We have scheduled a maintenance window that will specifically affect the testing of email aliases. During this time, test emails won't be sent in real-time but will be dispatched as soon as maintenance concludes.

Please be assured that this will not impact the main ImprovMX infrastructure or your regular email service.

Your understanding and patience are greatly appreciated as we continue to enhance our service. Thank you for your trust in ImprovMX.

Posted 5 Sep at 11:00pm CEST.