Back
Degraded

Temporary Email Delivery Degradation
Started 7 Jul at 01:28pm CEST, resolved 7 Jul at 01:36pm CEST.
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com
Resolved
We have identified the root cause of the issue and have implemented a fix.
We will be monitoring this to ensure that it remains stable.
You should start seeing your emails being delivered as the backlogs are gradually cleared from our infrastructure.
Posted 7 Jul at 01:36pm CEST.

Created
We are experiencing a temporary degradation of email delivery.
Our team is currently conducting a detailed investigation to identify and resolve this matter. Please be assured that this situation is being treated with the highest priority, and we're committed to restoring optimal performance as quickly as possible.
UPDATE: This has been resolved.
Posted 7 Jul at 01:28pm CEST.