Back to overview
Resolved

Investigating delayed mail delivery

Sep 15, 2026 at 11:47pm UTC
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Sep 16, 2026 at 12:54am UTC

We have identified the degraded performance due to a database query change recently. We have reverted the change, and services look to be returning to normal.

Created
Sep 15, 2026 at 11:47pm UTC

We received some alerts on database load, we're investigating.