Back to overview
Degraded

Degraded Deliverability to Microsoft & Outlook

Mar 07 at 12:39pm EST
Affected services
mx1.improvmx.com
mx2.improvmx.com
smtp.improvmx.com

Resolved
Mar 07 at 06:27pm EST

We have moved the affected servers out of rotation, so message deliverability to microsoft & outlook addresses should be returning to normal.

Created
Mar 07 at 12:39pm EST

A subset of our sending servers experiencing degraded deliverability to Microsoft & Outlook mail servers.

We are actively working on replacing these servers to restore high deliverability standards.